Buddy Commando does not hold its pressure.
Results 1 to 6 of 6

Thread: Buddy Commando does not hold its pressure.

  1. #1
    New Member ChangeAgent's Avatar
    Join Date
    Apr 2009
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Buddy Commando does not hold its pressure.

    Hi

    My Buddy Commando does not hold its pressure. I have it fully assembled and it does not hold its pressure overnight when I fully inflate it. Any idea as to how best check for where the leak could be?

    FYI I had AP Valves replace the bladder about 16 months ago as I had a hole in it.

  2. Remove Advertisements
    Yorkshire-Divers.com
    Advertisements
     

  3. #2
    Sorry for being a dick jb2cool's Avatar
    Join Date
    Apr 2006
    Location
    Bracknell, Berkshire
    Posts
    1,723
    Thanks
    34
    Thanked 197 Times in 171 Posts
    Fill it up and put it in a bath. There will be bubbles where the leak is.

  4. #3
    New Member
    Join Date
    Jan 2014
    Posts
    32
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Put soapy water over the valves and inflator areas first and check where the emergency cylinder attachment if fitted.
    If not there it will be your bladder again.

  5. Remove Advertisements
    Yorkshire-Divers.com
    Advertisements
     

  6. #4
    New Member ChangeAgent's Avatar
    Join Date
    Apr 2009
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Nick, I found the leak with your suggestion, it was the inflator blue button..

  7. #5
    www.eastcornwalldivers.co .uk JimmE's Avatar
    Join Date
    Apr 2009
    Location
    Newton Abbot, Devon, UK.
    Posts
    218
    Thanks
    29
    Thanked 35 Times in 19 Posts
    From memory, those are pretty easy to strip down and clean/inspect. AP should be able to help with any spare parts required, rather than just swapping the whole inflator.

  8. #6
    New Member ChangeAgent's Avatar
    Join Date
    Apr 2009
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for your answer.
    It was the blue inflator button that was leaking. They are super easy to take apart I always service them myself. Had the blue bit in stock and fixed it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •