YD Scuba Diving Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter · #1 ·
Last week I was a bit of a dunce and managed to drop my phone (Samsung S5600) in a jug of (fresh) water

The electricals are stll all working, but I'm having trouble with the buttons, so I can't now turn it back on.

Is threre anyone out there who can give me advice on how to fix it?

Ta,

Ash
 

·
Gone to pastures new
Joined
·
958 Posts
A friend did this wit two mobiles sometime back. I took the batteries out, stripped as much of the plastic case off as I could and got the circuit boards out. Then left them in the airing cupboard for a couple of days. One recovered fine, the other was wrecked.
 

·
Registered
Joined
·
2,824 Posts
Take the cover off and have a very close look at the ribbon cable for the keyboard. Has the very small connections corroded and fallen to pieces? I bet they have.......

My Palm did this when my big, yellow, waterproof pelican box sat in the gunnel for a little and the keyboard got wet thus proving that my pelican box was big and yellow but not waterproof.
 

·
Aspiring to the Horizontal
Joined
·
2,823 Posts
Take the cover off and have a very close look at the ribbon cable for the keyboard. Has the very small connections corroded and fallen to pieces? I bet they have.......

My Palm did this when my big, yellow, waterproof pelican box sat in the gunnel for a little and the keyboard got wet thus proving that my pelican box was big and yellow but not waterproof.
Was it one of the Peli boxes with the pressure equalisation valve on the front? The one that you can open and close......
 

·
Registered
Joined
·
201 Posts
Discussion Starter · #8 ·
thanks for all the replies!

i've got a pack of silica gel, so i've stuck it in an airtight container with my phone - we'll see what happens!

the phone's been apart several times! there's no evidence of corrosion, and i couldn't see the water damage sticker - maybe mine doesn't have one?!?!

the phone's a touchscreen - so no keyboard as such. there are three buttons at the bootom and 4 round the edge. they all work apart from the "answer call" button and "end call" button - which is also the on/off button! i've taken the "keypad" off and tried to use the buttons manually, but no luck.

hopefully drying it out properly will solve the prob!
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top