YD Scuba Diving Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter · #1 ·
Recently got my twinset back from test and found two potential problems with it. Can anyone explain whats probably wrong then I know whether to sort it myself or drop it back to the shop.

Problem 1:
Right hand post. Valve turns on fine and stops when its fully on. Turning the valve off you can turn the valve off for ever. It turns until the cylinder stops giving gas then can be continously turned.

Problem 2:
Left hand post. Can turn the valve for ever without it turning on.

Problem 1 occured straight after getting the cylinders back. Problem 2 took ten dives to develop.

Thanks for the advice
Mike
 

·
Mr potty mouth: Sweeping generalist...............
Joined
·
2,382 Posts
At a guess it's either something very very wrong or that the screw holding the handle on is not on tight enough this way the handle is not fully seated on the square valve spindle.
Try turning them while pushing the handle towards the stem, if it works then it's the easy solution...
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #4 ·
At a guess it's either something very very wrong or that the screw holding the handle on is not on tight enough this way the handle is not fully seated on the square valve spindle.
Try turning them while pushing the handle towards the stem, if it works then it's the easy solution...
Tried that and it didn't seem to make a difference. Cheers for the advice. Will drop them back to the shop later this week.
 

·
Technical Dive Instructor
Joined
·
384 Posts
sounds like the stem is not catching the seat. probably assembled with wrong parts, or handle is broken. this should never happen fresh from a service station!!!! Atrocious and potentially dangerous!
 
1 - 8 of 8 Posts
Top