YD Scuba Diving Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
912 Posts
Discussion Starter · #1 ·
Ive just been tinkering with my kit for a potential dive for the weekend. My second stage seems to be "leaking" or at least making a noise like it is. Ive altered the venturi switches in an effort to silence it but no joy. They've only been used a handful of times so they're fairly new.
Any ideas? or is it LDS....
XTX200
Cheers
Nick
 

·
Registered
Joined
·
912 Posts
Discussion Starter · #3 ·
Now im confused...

In the first instance I charged them up and down a couple of times to be sure there was an issue.

Just went back to them to try and identify where the problem was...all seems ok?

Will keep my eye on them over the comming days.

For my own peace of mind what could it have been, ive just returned from Turkey and took the regs with me if that has any bearings on it? As you can tell ive not got the greatest knowledge on regulator function.


Thanks anyway..
 

·
South African - and proud of it!
Joined
·
180 Posts
It could be a number of things and a high pressure leak from the seat in the first stage is not impossible - this used to happen to me a lot with several sets of ATX200s. To get a feel for what is happening, your local LDS should be able to check the inter-stage pressure for you and see if it is too high and/or creeping. If they're any cop, they shouldn't charge you (all it takes is a guage fitting to the LPI hose or into a LP port) and it'll help point you in the right direction.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top