YD Scuba Diving Forums banner
1 - 6 of 6 Posts

·
Silent Knight
Joined
·
1,849 Posts
Discussion Starter · #1 ·
On about 1 in 3 dives both Nic and my Salvo's begin to fire up and then die, needing to be switched off and on again and then they are normally OK.

Both are the 9 amp Nimh 21 watt variety and always have a fresh charge to night before use. They've probably only had about 12 hours in water time since new at the beginning of the year.

It's not a problem to fire them up again I just wanted to be sure it was a pretty normal afflication with how the HID bulb strikes. Our routine is to jump in and switch on at 6m whilst doing a kit/bubble check.

Cheers

Graham :)

.
 
G

·
I'd speak to that Knackers bloke, but it sounds like something isn't right

Neither of mine have ever failed except when I forgot to charge it :(
 

·
aka Chimp 1 or Mavis...
Joined
·
10,108 Posts
It's not a problem to fire them up again I just wanted to be sure it was a pretty normal afflication with how the HID bulb strikes. Our routine is to jump in and switch on at 6m whilst doing a kit/bubble check.
Personally, I fire it up on the boat/bench before getting in as then at least I have a chance to resolve any issues like not connecting the battery, not that that has happened to me before. :embarassed: Might also stop you doing the thing Garf did last year and be tempted to press on if it doesn't work and start the trip into the incident pit.
 

·
Registered
Joined
·
1,721 Posts
never had a problem with my 10w firing up apart from up in scapa when the battery was still downstairs in the bunkroom charging. was still kitted up and in the water before most of the rest of the boat ;)
 
1 - 6 of 6 Posts
Top