YD Scuba Diving Forums banner

1 - 7 of 7 Posts

·
Scooby-Do
Joined
·
1,501 Posts
Discussion Starter #1
The zip on my new O3 Ri is bloody stiff!

I've used wax on its own and zip lube on its own and a mix of the two but its still stiff.

If I zip lube just before use its looser.

Any ideas on how to get the zip running smoothly - never had this problem before on a suit - wax has always kept them running well.
 

·
more weaselly than a weaselly thing
Joined
·
3,628 Posts
lube the inneer teeth, they're the bit that actually engage/matter.
 
  • Like
Reactions: JamieG

·
Registered
Joined
·
628 Posts
wax, then use a hairdryer to melt it into the hard to reach spots :)
Is that not the solution to a number of sheewee problems

Seriously though, when I had problems I went over the waxed zip with a soft nail brush, this cleared off excess wax and "appeared" to smooth out what was left, may be worth a try
 

·
Scooby-Do
Joined
·
1,501 Posts
Discussion Starter #6
Is that not the solution to a number of sheewee problems

Seriously though, when I had problems I went over the waxed zip with a soft nail brush, this cleared off excess wax and "appeared" to smooth out what was left, may be worth a try
That zip is 'sublime' on your Predator suit mate! :)
 

·
Registered
Joined
·
628 Posts
Hi Jamie

Yep, can't say I've had any problems, has served me well through this winter. I've got a wing now, just waiting for the twin twelves before I do some serious diving, hopefully do Rec trimix in September

Good luck with the new suit mate, I'm sure you'll get there in the end
 
1 - 7 of 7 Posts
Top